aboutsummaryrefslogtreecommitdiffstats
path: root/include/osmocom/gsm/protocol/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2023-01-18 18:01:54 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2023-01-18 18:29:34 +0100
commit4fc6118bb3c0b49a07f6c4f4d612b7967f19ced7 (patch)
tree8bbbd12270667a740af5cde701510fedb5a5ba72 /include/osmocom/gsm/protocol/Makefile.am
parent1162a24454251c6813719cf2de22fa56abeeaff6 (diff)
Split include/Makefile.am content into subdirs
When someone is modifying a given library there's no need to be looking at a common file contains tons of lines from different libraries. Furthermore, this removes the need of "nobase" autofoo prefix, hence following the usual directive of having one Makefile per directory. Change-Id: I785891c2f89114bf8303c799094b637d3d25ac71
Diffstat (limited to 'include/osmocom/gsm/protocol/Makefile.am')
-rw-r--r--include/osmocom/gsm/protocol/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/include/osmocom/gsm/protocol/Makefile.am b/include/osmocom/gsm/protocol/Makefile.am
new file mode 100644
index 00000000..2ce3139d
--- /dev/null
+++ b/include/osmocom/gsm/protocol/Makefile.am
@@ -0,0 +1,28 @@
+osmogsmproto_HEADERS = \
+ gsm_23_032.h \
+ gsm_03_40.h \
+ gsm_03_41.h \
+ gsm_04_08.h \
+ gsm_04_08_gprs.h \
+ gsm_04_11.h \
+ gsm_04_12.h \
+ gsm_04_14.h \
+ gsm_04_80.h \
+ gsm_08_08.h \
+ gsm_08_58.h \
+ gsm_09_02.h \
+ gsm_12_21.h \
+ gsm_23_003.h \
+ gsm_23_041.h \
+ gsm_25_415.h \
+ gsm_29_118.h \
+ gsm_44_004.h \
+ gsm_44_318.h \
+ gsm_48_049.h \
+ gsm_48_071.h \
+ gsm_49_031.h \
+ ipaccess.h \
+ smpp34_osmocom.h \
+ $(NULL)
+
+osmogsmprotodir = $(includedir)/osmocom/gsm/protocol