aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2023-01-25 17:02:05 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2023-01-25 17:12:07 +0100
commit4eb89afa8004e887cb671787f3d119f8ca4e1f7f (patch)
treeeffe99636c177ad11a6144f2e4b0c3419560b58c /configure.ac
parent51e9dde95eb3eab16e572cff8b0f0841837201b8 (diff)
configure --enable-libmnl: Add libmnl to libosmocore.pc.in Requires
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1a87ec19..ee1c6f0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,7 +233,7 @@ AC_ARG_ENABLE([libmnl],
)],
[mnl=$enableval], [mnl="yes"])
AS_IF([test "x$mnl" = "xyes"], [
- PKG_CHECK_MODULES(LIBMNL, libmnl)
+ PKG_CHECK_MODULES(LIBMNL, libmnl, [AC_SUBST(LIBMNL_PC, [libmnl])])
AC_DEFINE([ENABLE_LIBMNL], [1], [Enable netlink socket support via libmnl])
])
AM_CONDITIONAL(ENABLE_LIBMNL, test "x$mnl" = "xyes")