aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2019-02-01 05:25:36 +0100
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2019-02-04 16:43:57 +0000
commit2fe50ac9511469a587426b80501b2b5da770e3a0 (patch)
treeee38028794ac52cd0a7a2100bcb564a3d8941869 /Makefile.am
parentc1aa178c8bc71129d13b7b47cfce4449bcec0c2c (diff)
doxygen: enable cross referencing everywhere
doxygen \ref cross-references to groups or files from other libraries only work when the .map file was present when the HTML was generated, and when that .map file was listed in TAGFILES in the Doxyfile. - Makefile.am: introduce a two-pass build for doxygen API docs. - First build pass makes sure the .tag files are present. - Second build pass picks up all the references, hence generates hyperlinks properly. - Add all libraries to TAGFILES of all other libraries, so we can from now on freely criss-cross reference from everywhere to everywhere. - Add all libraries' tag files as dependencies for all others. Example: in upcoming tdef.h, I would like to cross reference to tdef_vty.h, and vice versa, even though they are in libosmocore and libosmovty, respectively. This is now possible. We may still need to fix some problems with naming collisions, see for example stats.h, which exists twice with identical doxygen handle (different source dirs seems to not suffice for doxygen). Change-Id: Ib03d0b70d536c8f1386def666c89106a840f7363
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am144
1 files changed, 123 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index de5eb35d..9e0888f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,38 +39,140 @@ $(html_DATA): $(top_builddir)/doc/core/html/index.html \
$(top_builddir)/doc/gb/html/index.html
cd $(top_builddir)/doc && tar cf html.tar */html
-$(top_builddir)/doc/core/html/index.html: $(SOURCES) Doxyfile.core
- @rm -rf doc/core
- mkdir -p doc/core
+# Support doxygen cross references from each library to each other library:
+# First generate the docs to make sure all .tag files are in place.
+# In a second run, generate the content with proper referencing.
+# For example, libosmocore references tags from libosmovty and vice versa,
+# so both need to generate tag files first, and then do another run.
+#
+# Generate each docs tree, and touch a libosmofoo.tag.prep file when done.
+# It means that a libosmofoo.tag file is up-to-date.
+# Touch a separate "*.prep" target: libosmofoo.tag as target would create
+# circular dependency: we would rebuild all every time 'make' is invoked.
+# The .prep file also depends on all the source files for that library.
+
+$(top_builddir)/doc/libosmocore.tag.prep: $(top_builddir)/Doxyfile.core
+ rm -rf $(top_builddir)/doc/core; mkdir -p $(top_builddir)/doc/core
+ rm -rf $(top_builddir)/doc/libosmocore.map
+ -$(DOXYGEN) $(top_builddir)/Doxyfile.core
+ touch "$@"
+
+$(top_builddir)/doc/libosmogsm.tag.prep: $(top_builddir)/Doxyfile.gsm
+ rm -rf $(top_builddir)/doc/gsm; mkdir -p $(top_builddir)/doc/gsm
+ rm -rf $(top_builddir)/doc/libosmogsm.map
+ -$(DOXYGEN) $(top_builddir)/Doxyfile.gsm
+ touch "$@"
+
+$(top_builddir)/doc/libosmovty.tag.prep: $(top_builddir)/Doxyfile.vty
+ rm -rf $(top_builddir)/doc/vty; mkdir -p $(top_builddir)/doc/vty
+ rm -rf $(top_builddir)/doc/libosmovty.map
+ -$(DOXYGEN) $(top_builddir)/Doxyfile.vty
+ touch "$@"
+
+$(top_builddir)/doc/libosmocodec.tag.prep: $(top_builddir)/Doxyfile.codec
+ rm -rf $(top_builddir)/doc/codec; mkdir -p $(top_builddir)/doc/codec
+ rm -rf $(top_builddir)/doc/libosmocodec.map
+ -$(DOXYGEN) $(top_builddir)/Doxyfile.codec
+ touch "$@"
+
+$(top_builddir)/doc/libosmocoding.tag.prep: $(top_builddir)/Doxyfile.coding
+ rm -rf $(top_builddir)/doc/coding; mkdir -p $(top_builddir)/doc/coding
+ rm -rf $(top_builddir)/doc/libosmocoding.map
+ -$(DOXYGEN) $(top_builddir)/Doxyfile.coding
+ touch "$@"
+
+$(top_builddir)/doc/libosmoctrl.tag.prep: $(top_builddir)/Doxyfile.ctrl
+ rm -rf $(top_builddir)/doc/ctrl; mkdir -p $(top_builddir)/doc/ctrl
+ rm -rf $(top_builddir)/doc/libosmoctrl.map
+ -$(DOXYGEN) $(top_builddir)/Doxyfile.ctrl
+ touch "$@"
+
+$(top_builddir)/doc/libosmogb.tag.prep: $(top_builddir)/Doxyfile.gb
+ rm -rf $(top_builddir)/doc/gb; mkdir -p $(top_builddir)/doc/gb
+ rm -rf $(top_builddir)/doc/libosmogb.map
+ -$(DOXYGEN) $(top_builddir)/Doxyfile.gb
+ touch "$@"
+
+# Build for real once all depending .tag files are in place.
+# Depend on the own .tag.prep file to avoid concurrent builds of the same doc
+# tree, and to also depend on all the source files listed above.
+#
+# Each library should depend on all the tag.prep files of which it lists .tag
+# files in Doxyfile under TAGFILES.
+#
+# In turn, include all .tag files in TAGFILES of libraries to which "\ref"
+# references point.
+#
+# Easiest is to just depend on all tag.prep files all across everywhere.
+
+$(top_builddir)/doc/core/html/index.html: $(top_builddir)/doc/libosmocore.tag.prep \
+ $(top_builddir)/doc/libosmogsm.tag.prep \
+ $(top_builddir)/doc/libosmovty.tag.prep \
+ $(top_builddir)/doc/libosmocodec.tag.prep \
+ $(top_builddir)/doc/libosmocoding.tag.prep \
+ $(top_builddir)/doc/libosmoctrl.tag.prep \
+ $(top_builddir)/doc/libosmogb.tag.prep
+ rm -rf $(top_builddir)/doc/core; mkdir -p $(top_builddir)/doc/core
$(DOXYGEN) Doxyfile.core
-$(top_builddir)/doc/gsm/html/index.html: $(SOURCES) Doxyfile.gsm
- @rm -rf doc/gsm
- mkdir -p doc/gsm
+$(top_builddir)/doc/gsm/html/index.html: $(top_builddir)/doc/libosmogsm.tag.prep \
+ $(top_builddir)/doc/libosmocore.tag.prep \
+ $(top_builddir)/doc/libosmovty.tag.prep \
+ $(top_builddir)/doc/libosmocodec.tag.prep \
+ $(top_builddir)/doc/libosmocoding.tag.prep \
+ $(top_builddir)/doc/libosmoctrl.tag.prep \
+ $(top_builddir)/doc/libosmogb.tag.prep
+ rm -rf $(top_builddir)/doc/gsm; mkdir -p $(top_builddir)/doc/gsm
$(DOXYGEN) Doxyfile.gsm
-$(top_builddir)/doc/vty/html/index.html: $(SOURCES) Doxyfile.vty
- @rm -rf doc/vty/{html,latex}
+$(top_builddir)/doc/vty/html/index.html: $(top_builddir)/doc/libosmovty.tag.prep \
+ $(top_builddir)/doc/libosmocore.tag.prep \
+ $(top_builddir)/doc/libosmogsm.tag.prep \
+ $(top_builddir)/doc/libosmocodec.tag.prep \
+ $(top_builddir)/doc/libosmocoding.tag.prep \
+ $(top_builddir)/doc/libosmoctrl.tag.prep \
+ $(top_builddir)/doc/libosmogb.tag.prep
+ rm -rf $(top_builddir)/doc/vty; mkdir -p $(top_builddir)/doc/vty
$(DOXYGEN) Doxyfile.vty
-$(top_builddir)/doc/codec/html/index.html: $(SOURCES) Doxyfile.codec
- @rm -rf doc/codec
- mkdir -p doc/codec
+$(top_builddir)/doc/codec/html/index.html: $(top_builddir)/doc/libosmocodec.tag.prep \
+ $(top_builddir)/doc/libosmocore.tag.prep \
+ $(top_builddir)/doc/libosmogsm.tag.prep \
+ $(top_builddir)/doc/libosmovty.tag.prep \
+ $(top_builddir)/doc/libosmocoding.tag.prep \
+ $(top_builddir)/doc/libosmoctrl.tag.prep \
+ $(top_builddir)/doc/libosmogb.tag.prep
+ rm -rf $(top_builddir)/doc/codec; mkdir -p $(top_builddir)/doc/codec
$(DOXYGEN) Doxyfile.codec
-$(top_builddir)/doc/coding/html/index.html: Doxyfile.coding
- @rm -rf doc/coding
- mkdir -p doc/coding
+$(top_builddir)/doc/coding/html/index.html: $(top_builddir)/doc/libosmocoding.tag.prep \
+ $(top_builddir)/doc/libosmocore.tag.prep \
+ $(top_builddir)/doc/libosmogsm.tag.prep \
+ $(top_builddir)/doc/libosmovty.tag.prep \
+ $(top_builddir)/doc/libosmocodec.tag.prep \
+ $(top_builddir)/doc/libosmoctrl.tag.prep \
+ $(top_builddir)/doc/libosmogb.tag.prep
+ rm -rf $(top_builddir)/doc/coding; mkdir -p $(top_builddir)/doc/coding
$(DOXYGEN) Doxyfile.coding
-$(top_builddir)/doc/ctrl/html/index.html: $(SOURCES) Doxyfile.ctrl
- @rm -rf doc/ctrl
- mkdir -p doc/ctrl
+$(top_builddir)/doc/ctrl/html/index.html: $(top_builddir)/doc/libosmoctrl.tag.prep \
+ $(top_builddir)/doc/libosmocore.tag.prep \
+ $(top_builddir)/doc/libosmogsm.tag.prep \
+ $(top_builddir)/doc/libosmovty.tag.prep \
+ $(top_builddir)/doc/libosmocodec.tag.prep \
+ $(top_builddir)/doc/libosmocoding.tag.prep \
+ $(top_builddir)/doc/libosmogb.tag.prep
+ rm -rf $(top_builddir)/doc/ctrl; mkdir -p $(top_builddir)/doc/ctrl
$(DOXYGEN) Doxyfile.ctrl
-$(top_builddir)/doc/gb/html/index.html: $(SOURCES) Doxyfile.gb
- @rm -rf doc/gb
- mkdir -p doc/gb
+$(top_builddir)/doc/gb/html/index.html: $(top_builddir)/doc/libosmogb.tag.prep \
+ $(top_builddir)/doc/libosmocore.tag.prep \
+ $(top_builddir)/doc/libosmogsm.tag.prep \
+ $(top_builddir)/doc/libosmovty.tag.prep \
+ $(top_builddir)/doc/libosmocodec.tag.prep \
+ $(top_builddir)/doc/libosmocoding.tag.prep \
+ $(top_builddir)/doc/libosmoctrl.tag.prep
+ rm -rf $(top_builddir)/doc/gb; mkdir -p $(top_builddir)/doc/gb
$(DOXYGEN) Doxyfile.gb
install-data-hook:
@@ -79,7 +181,7 @@ install-data-hook:
uninstall-hook:
cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec,coding,ctrl,gb}
-DX_CLEAN = doc/{core,gsm,vty,codec,coding,ctrl,gb}/html/search/* doc/{core,gsm,vty,codec,coding,ctrl,gb}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding,ctrl,gb}/doxygen_sqlite3.db doc/*.tag
+DX_CLEAN = doc/{core,gsm,vty,codec,coding,ctrl,gb}/html/search/* doc/{core,gsm,vty,codec,coding,ctrl,gb}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding,ctrl,gb}/doxygen_sqlite3.db doc/*.tag doc/*.tag.prep
endif
MOSTLYCLEANFILES = $(DX_CLEAN)