aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2021-11-23 13:49:20 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2021-11-23 14:18:40 +0100
commitd4a1107586e8fefb18de10b9d68d63a2d3f1fe0d (patch)
tree6f0e7a33e262d2d95e3e040f37ddc0f23d27bb7e /src/Makefile.am
parent5967fa00580f07ddb428df0558e4d49aa1b7a7d1 (diff)
Introduce sctp.h to provide SCTP related functionalities
These value_strings are taken from existing private ones in libosmo-sccp.git osmo_ss7.c, and are moved here in order to be reused by other projects, such as osmo-hnodeb. Change-Id: Ica6f01851fb94e31f4ef097494bb1b8a95597ba6
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7e71c71..438b58e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,3 +20,7 @@ libosmonetif_la_SOURCES = amr.c \
rs232.c \
rtp.c \
stream.c
+
+if ENABLE_LIBSCTP
+libosmonetif_la_SOURCES += sctp.c
+endif