aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-12-21 20:54:19 +0100
committerHarald Welte <laforge@gnumonks.org>2015-12-21 20:54:19 +0100
commitfb3e20b4b2a38cd09bf4ed7687dacd3ab6f15d44 (patch)
tree5329298f7338e29c0044129af611621fccec8180 /configure.ac
parentd4be141ab0922427232db660e09befd064a6bace (diff)
SCTP support for osmo_stream_{cli,srv} code
Wih this change, osmo_stream_ client and server API can be used not only for TCP but also for SCTP. The latter is needed in SIGTRAN ad Iuh applications, for example.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3d4c4f0..42f3f42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,13 @@ PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.3.0)
dnl FIXME: We depend on libosmoabis by now until we can move LAPD code here
PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.0.7)
PKG_CHECK_MODULES(ORTP, ortp >= 0.15.0)
+AC_CHECK_LIB([sctp], [sctp_send], [
+ AC_DEFINE(HAVE_LIBSCTP, 1, [Define 1 to enable SCTP support])
+ AC_SUBST(HAVE_LIBSCTP, [1])
+ LIBS="-lsctp $LIBS"
+ ], [
+ AC_MSG_ERROR([libsctp not found])
+ ])
AC_CHECK_HEADERS(dahdi/user.h,,AC_MSG_WARN(DAHDI input driver will not be built))