aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 7a2a19382a..f0595000ac 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -24,11 +24,8 @@ include(UseABICheck)
if(WIN32)
set(WSUTIL_PLATFORM_FILES
file_util.c
- inet_aton.c
inet_ntop.c
inet_pton.c
- strptime.c
- wsgetopt.c
)
ENDIF(WIN32)
@@ -88,10 +85,22 @@ if(HAVE_SSE4_2)
set(WSUTIL_FILES ${WSUTIL_FILES} ws_mempbrk_sse42.c)
endif()
+if(NOT HAVE_GETOPT)
+ set(WSUTIL_FILES ${WSUTIL_FILES} wsgetopt.c)
+endif()
+
+if(NOT HAVE_INET_ATON)
+ set(WSUTIL_FILES ${WSUTIL_FILES} inet_aton.c)
+endif()
+
if(NOT HAVE_POPCOUNT)
set(WSUTIL_FILES ${WSUTIL_FILES} popcount.c)
endif()
+if(NOT HAVE_STRPTIME)
+ set(WSUTIL_FILES ${WSUTIL_FILES} strptime.c)
+endif()
+
if(APPLE)
#
# We assume that APPLE means OS X so that we have the OS X