aboutsummaryrefslogtreecommitdiffstats
path: root/writecap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'writecap/CMakeLists.txt')
-rw-r--r--writecap/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/writecap/CMakeLists.txt b/writecap/CMakeLists.txt
new file mode 100644
index 0000000000..582b8959b4
--- /dev/null
+++ b/writecap/CMakeLists.txt
@@ -0,0 +1,45 @@
+# CMakeLists.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+
+set(WRITECAP_SRC
+ pcapio.c
+)
+
+set(CLEAN_FILES
+ ${WRITECAP_SRC}
+)
+
+if (WERROR_COMMON_FLAGS)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
+ )
+endif()
+
+
+add_library(writecap STATIC
+ ${WRITECAP_SRC}
+)
+
+set_target_properties(writecap PROPERTIES
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ FOLDER "Libs")