aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'wiretap/configure.in')
-rw-r--r--wiretap/configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/wiretap/configure.in b/wiretap/configure.in
index d3afcd9794..734a90c43e 100644
--- a/wiretap/configure.in
+++ b/wiretap/configure.in
@@ -20,8 +20,20 @@ AM_PROG_LEX
AC_PROG_LIBTOOL
AC_PATH_PROG(LEX, flex)
-AC_SUBST(FLEX_PATH)
-
+#
+# Check whether Flex supports -R, so we can build reentrant scanners.
+#
+AC_MSG_CHECKING(whether Flex can generate reentrant scanners)
+if flex -R -t <<EOF >/dev/null 2>&1
+%%
+%%
+EOF
+then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(FLEX_REENTRANT_SCANNERS, 1, [Define if Flex can generate reentrant scanners])
+else
+ AC_MSG_RESULT(no)
+fi
#
# Try to add some additional gcc checks to CFLAGS