aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'wiretap/configure.in')
-rw-r--r--wiretap/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/wiretap/configure.in b/wiretap/configure.in
index 724ab2f2ef..09abc98989 100644
--- a/wiretap/configure.in
+++ b/wiretap/configure.in
@@ -40,7 +40,7 @@ AC_ARG_WITH(extra-gcc-checks,
wireshark_extra_gcc_flags=" -Wcast-qual -Wcast-align -Wbad-function-cast -pedantic -Wmissing-declarations -Wwrite-strings"
fi
],)
-AC_MSG_CHECKING(to see if we can add '-Wall -W -Wcast-qual $wireshark_extra_gcc_flags' to CFLAGS)
+AC_MSG_CHECKING(to see if we can add '-Wall -W -Wcast-qual -Werror $wireshark_extra_gcc_flags' to CFLAGS)
if test x$GCC != x ; then
CFLAGS="-D_U_=\"__attribute__((unused))\" -Wall -W $wireshark_extra_gcc_flags $CFLAGS"
AC_MSG_RESULT(yes)
@@ -49,6 +49,9 @@ else
AC_MSG_RESULT(no)
fi
+# Create the USING_GCC variable for use in Makefile.am files
+AM_CONDITIONAL(USING_GCC, test "x$GCC" != "x")
+
#
# Add any platform-specific compiler flags needed.
#