aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt36
1 files changed, 9 insertions, 27 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 7b4a8439ed..ad09591e56 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -141,6 +141,10 @@ set(WIRESHARK_QT_HEADERS
export_object_action.h
export_object_dialog.h
export_pdu_dialog.h
+ extcap_argument.h
+ extcap_argument_file.h
+ extcap_argument_multiselect.h
+ extcap_options_dialog.h
file_set_dialog.h
filter_action.h
filter_dialog.h
@@ -236,16 +240,6 @@ if(HAVE_PCAP_REMOTE)
)
endif()
-if(ENABLE_EXTCAP)
- set(WIRESHARK_QT_HEADERS
- ${WIRESHARK_QT_HEADERS}
- extcap_argument.h
- extcap_argument_file.h
- extcap_argument_multiselect.h
- extcap_options_dialog.h
- )
-endif()
-
file(GLOB EXTRA_QT_HEADERS
packet_list_record.h
models/sparkline_delegate.h
@@ -365,6 +359,10 @@ set(WIRESHARK_QT_SRC
export_object_action.cpp
export_object_dialog.cpp
export_pdu_dialog.cpp
+ extcap_argument.cpp
+ extcap_argument_file.cpp
+ extcap_argument_multiselect.cpp
+ extcap_options_dialog.cpp
file_set_dialog.cpp
filter_action.cpp
filter_dialog.cpp
@@ -454,16 +452,6 @@ if(HAVE_PCAP_REMOTE)
)
endif()
-if(ENABLE_EXTCAP)
- set(WIRESHARK_QT_SRC
- ${WIRESHARK_QT_SRC}
- extcap_argument.cpp
- extcap_argument_file.cpp
- extcap_argument_multiselect.cpp
- extcap_options_dialog.cpp
- )
-endif()
-
set(WIRESHARK_QT_TAP_SRC
${CMAKE_CURRENT_SOURCE_DIR}/expert_info_dialog.cpp
${CMAKE_CURRENT_SOURCE_DIR}/funnel_statistics.cpp
@@ -508,6 +496,7 @@ set(WIRESHARK_QT_UI
expert_info_dialog.ui
export_object_dialog.ui
export_pdu_dialog.ui
+ extcap_options_dialog.ui
file_set_dialog.ui
filter_dialog.ui
filter_expression_frame.ui
@@ -576,13 +565,6 @@ if(HAVE_PCAP_REMOTE)
)
endif()
-if(ENABLE_EXTCAP)
- set(WIRESHARK_QT_UI
- ${WIRESHARK_QT_UI}
- extcap_options_dialog.ui
- )
-endif()
-
set(WIRESHARK_QT_TS
wireshark_de.ts
wireshark_en.ts # lupdate -pluralonly