aboutsummaryrefslogtreecommitdiffstats
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index f2ab675294..334e5f3257 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -80,13 +80,11 @@ set(CLEAN_FILES
${COMMON_UI_SRC}
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
add_library(ui STATIC