aboutsummaryrefslogtreecommitdiffstats
path: root/tools/lemon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/lemon/CMakeLists.txt')
-rw-r--r--tools/lemon/CMakeLists.txt25
1 files changed, 18 insertions, 7 deletions
diff --git a/tools/lemon/CMakeLists.txt b/tools/lemon/CMakeLists.txt
index 3b44764c6e..bba72c3450 100644
--- a/tools/lemon/CMakeLists.txt
+++ b/tools/lemon/CMakeLists.txt
@@ -27,13 +27,11 @@ set(CLEAN_FILES
${lemon_FILES}
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
set(lemon_LIBS
# Do we need something here on any platform?
@@ -44,3 +42,16 @@ set_target_properties(lemon PROPERTIES FOLDER "tools")
set_target_properties(lemon PROPERTIES COMPILE_OPTIONS "${WS_WARNINGS_C_FLAGS}")
target_link_libraries(lemon ${lemon_LIBS})
+
+#
+# Editor modelines - http://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#