aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/tpg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/tpg/CMakeLists.txt')
-rw-r--r--plugins/tpg/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/plugins/tpg/CMakeLists.txt b/plugins/tpg/CMakeLists.txt
index 066f68f300..91c1f7a6cd 100644
--- a/plugins/tpg/CMakeLists.txt
+++ b/plugins/tpg/CMakeLists.txt
@@ -71,9 +71,18 @@ add_library(tpg ${LINK_MODE_MODULE}
${PLUGIN_FILES}
plugin.rc
)
-set_target_properties(tpg PROPERTIES PREFIX "")
-set_target_properties(tpg PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
-set_target_properties(tpg PROPERTIES FOLDER "Plugins")
+
+set_target_properties(tpg PROPERTIES
+ PREFIX ""
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ FOLDER "Plugins"
+)
+
+if(ENABLE_APPLICATION_BUNDLE)
+ set_target_properties(tpg PROPERTIES
+ LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark
+ )
+endif()
target_link_libraries(tpg epan)