aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/interlink/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/interlink/CMakeLists.txt')
-rw-r--r--plugins/interlink/CMakeLists.txt65
1 files changed, 65 insertions, 0 deletions
diff --git a/plugins/interlink/CMakeLists.txt b/plugins/interlink/CMakeLists.txt
new file mode 100644
index 0000000000..a4a9c495fe
--- /dev/null
+++ b/plugins/interlink/CMakeLists.txt
@@ -0,0 +1,65 @@
+# CMakeLists.txt
+#
+# $Id: CMakeLists.txt 31995 2010-02-24 22:32:10Z jmayer $
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+set(DISSECTOR_SRC
+ packet-interlink.c
+)
+
+set(PLUGIN_FILES
+ plugin.c
+ ${DISSECTOR_SRC}
+)
+
+set(CLEAN_FILES
+ ${PLUGIN_FILES}
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+register_dissector_files(plugin.c
+ plugin
+ ${DISSECTOR_SRC}
+)
+
+add_library(interlink ${LINK_MODE_MODULE}
+ ${PLUGIN_FILES}
+)
+set_target_properties(interlink PROPERTIES PREFIX "")
+#set_target_properties(interlink PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+
+target_link_libraries(interlink epan)
+
+install(TARGETS interlink
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+)
+