aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/ethercat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ethercat/CMakeLists.txt')
-rw-r--r--plugins/ethercat/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/plugins/ethercat/CMakeLists.txt b/plugins/ethercat/CMakeLists.txt
index 540e103c35..6c227b46ec 100644
--- a/plugins/ethercat/CMakeLists.txt
+++ b/plugins/ethercat/CMakeLists.txt
@@ -56,13 +56,9 @@ register_plugin_files(plugin.c
${DISSECTOR_SRC}
)
-add_plugin_library(ethercat)
+add_plugin_library(ethercat epan)
-install(TARGETS ethercat
- LIBRARY DESTINATION ${PLUGIN_INSTALL_LIBDIR} NAMELINK_SKIP
- RUNTIME DESTINATION ${PLUGIN_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${PLUGIN_INSTALL_LIBDIR}
-)
+install_plugin(ethercat epan)
file(GLOB DISSECTOR_HEADERS RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "*.h")
CHECKAPI(