aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/epan/transum/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/epan/transum/Makefile.am')
-rw-r--r--plugins/epan/transum/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/plugins/epan/transum/Makefile.am b/plugins/epan/transum/Makefile.am
new file mode 100644
index 0000000000..615255c66b
--- /dev/null
+++ b/plugins/epan/transum/Makefile.am
@@ -0,0 +1,71 @@
+# Makefile.am
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+include $(top_srcdir)/Makefile.am.inc
+include $(top_srcdir)/plugins/Makefile.am.inc
+
+# the name of the plugin
+PLUGIN_NAME = transum
+
+PLUGIN_VERSION = 2.0.2
+
+BUILT_SOURCES = \
+ plugin.c
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-transum.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES) \
+ decoders.c \
+ extractors.c
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ decoders.h \
+ extractors.h \
+ packet-transum.h \
+ preferences.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
+epan_plugin_LTLIBRARIES = transum.la
+
+transum_la_SOURCES = \
+ $(SRC_FILES) \
+ $(HEADER_FILES)
+
+nodist_transum_la_SOURCES = \
+ plugin.c
+
+transum_la_CPPFLAGS = $(AM_CPPFLAGS) $(PLUGIN_CPPFLAGS)
+
+transum_la_CFLAGS = $(AM_CFLAGS) $(PLUGIN_CFLAGS)
+
+transum_la_LDFLAGS = $(PLUGIN_LDFLAGS)
+
+DISTCLEANFILES = \
+ plugin.c
+
+EXTRA_DIST = \
+ CMakeLists.txt