aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/lrexlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'epan/wslua/lrexlib/CMakeLists.txt')
-rw-r--r--epan/wslua/lrexlib/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/epan/wslua/lrexlib/CMakeLists.txt b/epan/wslua/lrexlib/CMakeLists.txt
new file mode 100644
index 0000000000..2f7231efe3
--- /dev/null
+++ b/epan/wslua/lrexlib/CMakeLists.txt
@@ -0,0 +1,30 @@
+
+set(REX_SRC
+ common.c
+ pcre2/lpcre2.c
+ pcre2/lpcre2_f.c
+)
+
+add_library(lrexlib STATIC ${REX_SRC})
+
+target_link_libraries(lrexlib PRIVATE
+ ${LUA_LIBRARIES}
+ $<IF:$<CONFIG:Debug>,${PCRE2_DEBUG_LIBRARIES},${PCRE2_LIBRARIES}>
+)
+
+target_include_directories(lrexlib SYSTEM PRIVATE
+ ${CMAKE_SOURCE_DIR}/epan
+ ${LUA_INCLUDE_DIRS}
+ ${PCRE2_INCLUDE_DIRS}
+)
+
+add_dependencies(lrexlib register_wslua)
+
+if(FETCH_lua)
+ add_dependencies(lrexlib lua52)
+endif()
+
+add_compile_definitions(
+ VERSION=\"2.9.1\"
+ PCRE2_CODE_UNIT_WIDTH=8
+)