aboutsummaryrefslogtreecommitdiffstats
path: root/epan/ftypes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'epan/ftypes/CMakeLists.txt')
-rw-r--r--epan/ftypes/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/epan/ftypes/CMakeLists.txt b/epan/ftypes/CMakeLists.txt
index 32b313e5b9..50df55c34b 100644
--- a/epan/ftypes/CMakeLists.txt
+++ b/epan/ftypes/CMakeLists.txt
@@ -41,13 +41,11 @@ set(FTYPE_FILES
)
source_group(ftype FILES ${FTYPE_FILES})
-if(WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${FTYPE_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${FTYPE_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
add_library(ftypes OBJECT
${FTYPE_FILES}