aboutsummaryrefslogtreecommitdiffstats
path: root/epan/crypt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'epan/crypt/CMakeLists.txt')
-rw-r--r--epan/crypt/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/epan/crypt/CMakeLists.txt b/epan/crypt/CMakeLists.txt
index cb659c3998..a06aa60482 100644
--- a/epan/crypt/CMakeLists.txt
+++ b/epan/crypt/CMakeLists.txt
@@ -35,13 +35,11 @@ set(CRYPT_FILES
)
source_group(crypt FILES ${CRYPT_FILES})
-if(WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CRYPT_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CRYPT_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
add_library(crypt OBJECT
${CRYPT_FILES}