aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am25
1 files changed, 4 insertions, 21 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index dbb70d70ae..5585b3a74e 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -56,7 +56,7 @@ ACLOCAL_AMFLAGS = `../aclocal-flags`
noinst_LTLIBRARIES = libwireshark_generated.la libwireshark_asmopt.la
lib_LTLIBRARIES = libwireshark.la
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-libwireshark_la_LDFLAGS = -version-info 0:0:0 -export-symbols libwireshark.sym @LDFLAGS_SHAREDLIB@
+libwireshark_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
include Makefile.common
@@ -64,9 +64,10 @@ INCLUDES = -I$(srcdir)/.. -I$(srcdir)/$(LEMON) -I$(builddir)/wslua \
@LUA_INCLUDES@ $(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) \
$(LIBSMI_CFLAGS) $(LIBGEOIP_CFLAGS) $(PY_CFLAGS)
+AM_NON_GENERATED_CFLAGS =-DWS_BUILD_DLL
if HAVE_WARNINGS_AS_ERRORS
-AM_NON_GENERATED_CFLAGS = -Werror
+AM_NON_GENERATED_CFLAGS += -Werror
endif
#Since code generated by lex may trigger gcc warnings, we are now generating two
@@ -100,7 +101,6 @@ EXTRA_DIST = \
dtd_parse.h \
dtd_preparse.l \
enterprise-numbers \
- libwireshark.def \
libwireshark.vcproj \
Makefile.common \
Makefile.nmake \
@@ -119,7 +119,6 @@ CLEANFILES = \
libwireshark_generated.la \
libwireshark_asmopt.a \
libwireshark_asmopt.la \
- libwireshark.sym \
*~
DISTCLEANFILES = \
@@ -152,8 +151,7 @@ libwireshark_la_DEPENDENCIES = \
ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
dissectors/libdirtydissectors.la wmem/libwmem.la $(wslua_lib) $(wspython_lib) \
${top_builddir}/wsutil/libwsutil.la \
- ${top_builddir}/wiretap/libwiretap.la \
- libwireshark.sym
+ ${top_builddir}/wiretap/libwiretap.la
EXTRA_PROGRAMS = reassemble_test
reassemble_test_LDADD = \
@@ -192,21 +190,6 @@ tvbtest.o exntest.o: exceptions.h
sminmpec.c: enterprise-numbers ../tools/make-sminmpec.pl
$(PERL) $(srcdir)/../tools/make-sminmpec.pl $(srcdir)/enterprise-numbers sminmpec.c
-def_sym_filter_symbols =
-
-if !HAVE_PLUGINS
-# If we're not building plugins, these symbols don't get built.
-# Keep them out of the symbol list.
-def_sym_filter_symbols += /^register_all_plugin_tap_listeners/ || /^plugin_list/ {next;};
-endif
-
-if !HAVE_LIBPY
-# If we're not building python, these symbols don't get built.
-# Keep them out of the symbol list.
-def_sym_filter_symbols += /^py_create_dissector_handle/ || /^py_dissector_args/ {next;};
-def_sym_filter_symbols += /^py_generic_dissector/ || /^py_pinfo/ || /^py_tree/ || /^py_tvbuff/ {next;};
-def_sym_filter_symbols += /^hf_register_info_add/ || /^hf_register_info_create/ || /^hf_register_info_destroy/ {next;};
-endif
if HAVE_PLUGINS