aboutsummaryrefslogtreecommitdiffstats
path: root/echld/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'echld/CMakeLists.txt')
-rw-r--r--echld/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/echld/CMakeLists.txt b/echld/CMakeLists.txt
index a7e3701be4..257c301598 100644
--- a/echld/CMakeLists.txt
+++ b/echld/CMakeLists.txt
@@ -39,11 +39,11 @@ set(ECHLD_FILES
${DIRTY_FILES}
)
-if (WERROR)
+if (WERROR_COMMON_FLAGS)
set_source_files_properties(
${CLEAN_FILES}
PROPERTIES
- COMPILE_FLAGS -Werror
+ COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
)
endif()
@@ -92,4 +92,3 @@ if(NOT ${ENABLE_STATIC})
ARCHIVE DESTINATION lib
)
endif()
-