aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules150
1 files changed, 40 insertions, 110 deletions
diff --git a/debian/rules b/debian/rules
index 0c122feb17..77c8e774e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,130 +1,60 @@
#!/usr/bin/make -f
-# Made with the aid of dh_make, by Craig Small
+# Originally made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Cristoph Lameter.
+# Rewritten to use dh, by Balint Reczey
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-include /usr/share/dpatch/dpatch.make
-DB2MAN=/usr/share/xml/docbook/stylesheet/nwalsh/manpages/docbook.xsl
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: \(.*\)-.*/\1/p')
+export docdir = /usr/share/doc/wireshark-doc
+%:
+ dh $@ --with python2 --buildsystem cmake # --parallel
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+override_dh_auto_configure:
+ dh_auto_configure -- -DENABLE_GUIDES=ON -DCMAKE_INSTALL_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ -DENABLE_QT5=OFF
-PYTHON_VERSION=python2.4
-
-CFLAGS=-g -O2
-
-# Enable IEEE-conformant floating point math on alphas (not the default)
-ifeq (alpha-linux,$(DEB_HOST_GNU_TYPE))
- CFLAGS += -mieee
-endif
-
-CONFIGURE_FLAGS=--prefix=/usr --sysconfdir=/usr/share --datadir=/usr/share --libdir=/usr/lib/wireshark --disable-static --enable-warnings-as-errors=no --enable-setuid-install --with-plugins=/usr/lib/wireshark/plugins --with-lua=/usr/
-
-configure: configure-stamp
-configure-stamp: patch
- dh_testdir
-
- cp /usr/share/misc/config.guess /usr/share/misc/config.sub .
- libtoolize --force --copy
- -mkdir aclocal-missing
- ./autogen.sh
- CFLAGS="$(CFLAGS)" ./configure $(CONFIGURE_FLAGS)
-
- touch configure-stamp
-
-build: build-stamp
-build-stamp: configure-stamp
- $(MAKE)
+override_dh_auto_build:
+ dh_auto_build
+ # create menu icon
convert image/wsicon32.png image/wsicon32.xpm
- touch build-stamp
-
-patch: patch-stamp
-patch-stamp:
- dpatch apply-all
-
-
-clean: unpatch-stamp
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -f rdps wireshark.1 tshark.1 wireshark-filter.4
- rm -f conftest conftest.c
- rm -f config.guess config.sub config.log
- rm -f config.h.in config.h configure
-
- dh_clean
-
-unpatch: unpatch-stamp
-unpatch-stamp:
- dpatch deapply-all
- rm -rf patch-stamp debian/patched
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the files into debian/tmp
- $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
- mkdir -p $(CURDIR)/debian/tmp/usr/share/applications/
- cp debian/wireshark.desktop $(CURDIR)/debian/tmp/usr/share/applications/
- cp tools/asn2deb tools/idl2deb tools/idl2wrs $(CURDIR)/debian/tmp/usr/bin/
- #cp debian/wireshark-root.desktop $(CURDIR)/debian/tmp/usr/share/applications/
- mkdir -p $(CURDIR)/debian/tmp/usr/share/pixmaps/
- cp image/hi48-app-wireshark.png $(CURDIR)/debian/tmp/usr/share/pixmaps/
- cp image/wsicon32.xpm $(CURDIR)/debian/tmp/usr/share/pixmaps/
+ # fix links in documentation
+ sed -i "s|$(CURDIR)/docbook|..|" obj-*/docbook/ws*g_html_chunked/*
+
+override_dh_strip:
+ dh_strip --dbg-package=wireshark-dbg
+
+override_dh_auto_install:
+ dh_auto_install
+ rm -f debian/*.shlibs
+ rm -rf $(CURDIR)/debian/tmp/usr/share/wireshark/COPYING
+ cp debian/license-text-about-dialog $(CURDIR)/debian/tmp/usr/share/wireshark/ABOUT.GPL
+ # icons conforming to freedesktop.org standards
+ mkdir -p $(CURDIR)/debian/tmp/usr/share/icons/hicolor/scalable/apps/ \
+ $(CURDIR)/debian/tmp/usr/share/mime/packages/
+ install -m 644 image/wsicon.svg $(CURDIR)/debian/tmp/usr/share/icons/hicolor/scalable/apps/wireshark.svg
+ install -m 644 wireshark-mime-package.xml $(CURDIR)/debian/tmp/usr/share/mime/packages/wireshark.xml
+ # upstream uses qtshark for binary's name
+ mv $(CURDIR)/debian/tmp/usr/bin/qtshark $(CURDIR)/debian/tmp/usr/bin/wireshark-qt
mkdir -p $(CURDIR)/debian/tmp/etc/wireshark/
mv $(CURDIR)/debian/tmp/usr/share/wireshark/init.lua \
$(CURDIR)/debian/tmp/etc/wireshark/
ln -s /etc/wireshark/init.lua \
$(CURDIR)/debian/tmp/usr/share/wireshark/init.lua
- mkdir -p $(CURDIR)/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
- cp $(CURDIR)/tools/wireshark_be.py $(CURDIR)/tools/wireshark_gen.py \
- $(CURDIR)/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
- mkdir -p $(CURDIR)/debian/tmp/usr/include/wireshark/
- for F in `cat debian/wireshark-dev.header-files`; do \
- cp --parents $$F $(CURDIR)/debian/tmp/usr/include/wireshark; \
- done
- -rm -rf $(CURDIR)/debian/tmp/usr/man
- mkdir -p $(CURDIR)/debian/tmp/usr/man
- dh_installman
- cp doc/asn2deb.1 doc/idl2deb.1 doc/idl2wrs.1 $(CURDIR)/debian/tmp/usr/man
- dh_movefiles
- dh_pysupport
- dh_installdocs
- dh_installmenu
- dh_installchangelogs NEWS
-
-# Build architecture-independent files here.
-binary-indep: install
-# We have nothing to do by default.
-
-check: install
+override_dh_install:
+ dh_install
# check all necessary headers are included
- gcc -c debian/headers-check.c `pkg-config --cflags glib-2.0` -Idebian/wireshark-dev/usr/include/ -Idebian/wireshark-dev/usr/include/wireshark/ -o /dev/null
-
-# Build architecture-dependent files here.
-binary-arch: install check
- dh_strip
- dh_compress
- dh_fixperms -Xdumpcap
-
- dh_installdeb
- LD_LIBRARY_PATH=/usr/lib/wireshark/:/usr/lib/libfakeroot/ dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+ $(CC) -c debian/headers-check.c `pkg-config --cflags glib-2.0` -Idebian/libwireshark-dev/usr/include -Idebian/libwireshark-dev/usr/include/wireshark -Idebian/libwiretap-dev/usr/include/wireshark -Idebian/libwsutil-dev/usr/include/wireshark -o /dev/null
-source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+override_dh_fixperms:
+ dh_fixperms
+ chmod 644 debian/wireshark-dev/usr/share/pyshared/wireshark_be.py \
+ debian/wireshark-dev/usr/share/pyshared/wireshark_gen.py
-binary: binary-indep binary-arch
-.PHONY: build clean install check binary-indep binary-arch binary