aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 13 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3e8b031af7..1856a4f6be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1640,10 +1640,23 @@ if test "x$enable_wireshark" = "xyes"; then
CXXFLAGS="$CXXFLAGS $Qt_CFLAGS"
have_qt=yes
GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-qt"
+
+ #
+ # XXX - greasy hack to make ui/gtk/recent.c
+ # compile.
+ #
+ CPPFLAGS="-DQT_GUI_LIB"
],
[
case "$with_qt" in
+ unspecified)
+ #
+ # They didn't explicitly ask for Qt,
+ # so just don't build with it.
+ #
+ ;;
+
yes)
AC_MSG_ERROR([Qt is not available])
;;
@@ -1657,12 +1670,6 @@ if test "x$enable_wireshark" = "xyes"; then
;;
esac
])
-
- #
- # XXX - greasy hack to make ui/gtk/recent.c
- # compile.
- #
- CPPFLAGS="-DQT_GUI_LIB"
fi
if test "x$with_gtk3" = "xyes"; then