aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e3b3327215..7b52c8cd85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1333,7 +1333,8 @@ if test "x$enable_wireshark" = "xyes"; then
[
CFLAGS="$CFLAGS $Qt_CFLAGS"
CXXFLAGS="$CXXFLAGS $Qt_CFLAGS"
- have_qt=yes
+ have_qt=yes
+ GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-qt"
],
[AC_MSG_ERROR([Qt is not available])])
@@ -1362,6 +1363,7 @@ if test "x$enable_wireshark" = "xyes"; then
CFLAGS="$CFLAGS $GTK_CFLAGS"
CXXFLAGS="$CXXFLAGS $GTK_CFLAGS"
have_gtk=yes
+ GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-gtk3"
],
[AC_MSG_ERROR([GTK+ 3 is not available])])
elif test "x$with_gtk2" = "xyes"; then
@@ -1374,10 +1376,12 @@ if test "x$enable_wireshark" = "xyes"; then
CFLAGS="$CFLAGS $GTK_CFLAGS"
CXXFLAGS="$CXXFLAGS $GTK_CFLAGS"
have_gtk=yes
+ GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-gtk2"
],
[AC_MSG_ERROR([GTK+ 2 is not available])])
fi
fi
+AC_SUBST(GUI_CONFIGURE_FLAGS)
GLIB_MIN_VERSION=2.16.0
AC_SUBST(GLIB_MIN_VERSION)