aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b553b0b9de..0c4dcc1478 100644
--- a/configure.ac
+++ b/configure.ac
@@ -809,6 +809,14 @@ fi
AC_SUBST(HAVE_OSX_PACKAGING)
#
+# Use this as a proxy for "is this OS X" (just in case somebody actually
+# built and installed Darwin as an OS, perhaps with some X11-based GUI,
+# don't look for Darwin).
+#
+AC_CHECK_PROG(have_sw_vers, sw_vers, "yes", "no")
+AM_CONDITIONAL(NOT_OS_X, test "x$have_sw_vers" = "xno")
+
+#
# Some compilers have to be told to fail when passed an unknown -W flag;
# make sure we do that.
#