aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fb865fb662..bc081a9766 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2265,9 +2265,11 @@ if test "x$enable_setcap_install" = "xno" ; then
AC_MSG_RESULT(no)
else
if test "x$SETCAP" = "x" ; then
- AC_MSG_RESULT(no. Setcap not found)
+ AC_MSG_RESULT(setcap not found)
+ AC_MSG_ERROR([Setcap install was requested, but setcap was not found])
elif test "x$enable_dumpcap" = "xno" ; then
- AC_MSG_ERROR(Setcap install works only with dumpcap but dumpcap is disabled)
+ AC_MSG_RESULT(dumpcap disabled)
+ AC_MSG_ERROR([Setcap install works only with dumpcap, but dumpcap is disabled])
else
AC_MSG_RESULT(yes)
fi
@@ -2287,9 +2289,11 @@ if test "x$enable_setuid_install" = "xno" ; then
else
if test "x$enable_setcap_install" = "xyes" ; then
enable_setuid_install=no
- AC_MSG_RESULT(no; using setcap instead)
+ AC_MSG_RESULT(setcap and setuid both selected)
+ AC_MSG_ERROR(You must choose one of setcap install and setuid install)
elif test "x$enable_dumpcap" = "xno" ; then
- AC_MSG_ERROR(Setuid install works only with dumpcap but dumpcap is disabled)
+ AC_MSG_RESULT(dumpcap disabled)
+ AC_MSG_ERROR([Setuid install works only with dumpcap, but dumpcap is disabled])
else
AC_MSG_RESULT(yes)
fi