aboutsummaryrefslogtreecommitdiffstats
path: root/codecs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'codecs/CMakeLists.txt')
-rw-r--r--codecs/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/codecs/CMakeLists.txt b/codecs/CMakeLists.txt
index 34bd7be885..4595054059 100644
--- a/codecs/CMakeLists.txt
+++ b/codecs/CMakeLists.txt
@@ -23,10 +23,6 @@ set(WSCODECS_FILES
codecs.c
G711a/G711adecode.c
G711u/G711udecode.c
- # These are wrapped in "#ifdef HAVE_SPANDSP", which we don't currently
- # handle or define.
- # G722/G722decode.c
- # G726/G726decode.c
speex/resample.c
)
@@ -51,6 +47,11 @@ set(wscodecs_LIBS
wsutil
)
+if(HAVE_SPANDSP)
+ list(APPEND WSCODECS_FILES G722/G722decode.c G726/G726decode.c)
+ list(APPEND wscodecs_LIBS ${SPANDSP_LIBRARIES})
+endif()
+
add_library(wscodecs ${LINK_MODE_LIB}
${WSCODECS_FILES}
${CMAKE_BINARY_DIR}/image/libwscodecs.rc