aboutsummaryrefslogtreecommitdiffstats
path: root/capchild/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'capchild/CMakeLists.txt')
-rw-r--r--capchild/CMakeLists.txt25
1 files changed, 18 insertions, 7 deletions
diff --git a/capchild/CMakeLists.txt b/capchild/CMakeLists.txt
index af51706305..b470a4db08 100644
--- a/capchild/CMakeLists.txt
+++ b/capchild/CMakeLists.txt
@@ -30,13 +30,11 @@ set(CLEAN_FILES
${CAPCHILD_SRC}
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
file(GLOB CAPCHILD_HEADERS capture_session.h)
@@ -66,3 +64,16 @@ CHECKAPI(
SOURCES
${CAPCHILD_SRC}
)
+
+#
+# Editor modelines - http://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#