aboutsummaryrefslogtreecommitdiffstats
path: root/asn1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'asn1/CMakeLists.txt')
-rw-r--r--asn1/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/asn1/CMakeLists.txt b/asn1/CMakeLists.txt
index 821af65893..15fcbf4e49 100644
--- a/asn1/CMakeLists.txt
+++ b/asn1/CMakeLists.txt
@@ -130,7 +130,11 @@ set( BROKEN_ASN1_SRC_DIRS
x721
)
+set(_asn1_deps)
foreach(ASN1_DIR ${ASN1_SRC_DIRS})
add_subdirectory( ${ASN1_DIR} )
+ list(APPEND _asn1_deps ${ASN1_DIR}/generate_dissector-${ASN1_DIR})
endforeach()
+# Target to regenerate all outdated ASN.1 dissectors
+add_custom_target(asn1 DEPENDS ${_asn1_deps})