aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index a4c5fd5c66..bb11d6d13c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -381,17 +381,27 @@ dftest_LDADD = \
dftest_LDFLAGS = -export-dynamic
-CLEANFILES = \
- svnversion.h \
- @rdps_bin@ \
- idl2eth
+#
+# XXX - "svnversion.h" is distributed in the release tarball; should
+# we be deleting it with "make clean", or should we only do that with
+# "make maintainer-clean"?
+#
+CLEANFILES = \
+ svnversion.h \
+ @rdps_bin@ \
+ idl2eth \
+ *~
+#
+# XXX - "ps.c" is distributed in the source tarballs; why is it in the
+# list of files removed by "make distclean"? (It's deliberately
+# included in that list.)
+#
DISTCLEANFILES = \
- ps.c \
- *~
+ ps.c
MAINTAINERCLEANFILES = \
- ps.c
+ $(GENERATED_FILES)
EXTRA_DIST = \
AUTHORS-SHORT \