aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36adea0a6d..9b5c5d2917 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1433,9 +1433,26 @@ if(ENABLE_PLUGINS)
plugins/epan/wimaxasncp
plugins/epan/wimaxmacphy
plugins/wiretap/usbdump
+ plugins/codecs/G711
plugins/codecs/l16_mono
${CUSTOM_PLUGIN_SRC_DIR}
)
+ if(SPANDSP_FOUND)
+ list(APPEND PLUGIN_SRC_DIRS
+ plugins/codecs/G722
+ plugins/codecs/G726
+ )
+ endif()
+ if(BCG729_FOUND)
+ list(APPEND PLUGIN_SRC_DIRS
+ plugins/codecs/G729
+ )
+ endif()
+ if(SBC_FOUND)
+ list(APPEND PLUGIN_SRC_DIRS
+ plugins/codecs/sbc
+ )
+ endif()
# Build demo plugin, only if asked explicitly
if(ENABLE_PLUGIN_IFDEMO)