aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5893baa28b..89d50309da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1236,11 +1236,11 @@ add_custom_target(dist
)
if(GNUTLS_FOUND AND NOT GNUTLS_VERSION VERSION_LESS "3.4.0")
- # While all Linux and Windows builds have PKCS #11 support enabled,
- # macos-setup.sh explicitly disables it using --without-p11-kit.
+ # Calculating public keys from PKCS #11 private keys requires GnuTLS
+ # 3.4.0 or greater.
#
- # Require at least GnuTLS 3.4.0 such that public keys can be calculated
- # from PKCS #11 private keys.
+ # Check that the support is present in case GnuTLS was compiled
+ # --without-p11-kit as macos-setup.sh did until recently.
include(CheckSymbolExists)
cmake_push_check_state()
if(WIN32)