aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ed890da42..1277664389 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -823,6 +823,13 @@ else() # ! MSVC
elseif(DISABLE_ASSERT)
add_definitions(-DWS_DISABLE_ASSERT)
endif()
+ if(ENABLE_DEBUG)
+ add_definitions(-DWS_DEBUG)
+ elseif(CMAKE_VERSION VERSION_GREATER "3.11.99")
+ add_compile_definitions(
+ $<$<CONFIG:Debug>:WS_DEBUG>
+ )
+ endif()
set(WIRESHARK_LD_FLAGS
# See also CheckCLinkerFlag.cmake