aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b25965ad11..7f4a36663c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -921,7 +921,6 @@ set(SHARK_COMMON_SRC
capture-pcap-util.c
cfile.c
frame_tvbuff.c
- ${CMAKE_BINARY_DIR}/version.h
sync_pipe_write.c
version_info.c
)
@@ -1221,6 +1220,7 @@ if(BUILD_text2pcap)
set(text2pcap_CLEAN_FILES
text2pcap.c
pcapio.c
+ version_info.c
)
set(text2pcap_FILES
${text2pcap_CLEAN_FILES}
@@ -1245,7 +1245,7 @@ if(BUILD_mergecap)
)
set(mergecap_FILES
mergecap.c
- ${CMAKE_BINARY_DIR}/version.h
+ version_info.c
image/mergecap.rc
)
add_executable(mergecap ${mergecap_FILES})
@@ -1264,7 +1264,7 @@ if(BUILD_reordercap)
)
set(reordercap_FILES
reordercap.c
- ${CMAKE_BINARY_DIR}/version.h
+ version_info.c
image/reordercap.rc
)
add_executable(reordercap ${reordercap_FILES})
@@ -1285,6 +1285,7 @@ if(BUILD_capinfos)
)
set(capinfos_FILES
capinfos.c
+ version_info.c
image/capinfos.rc
)
add_executable(capinfos ${capinfos_FILES})
@@ -1322,6 +1323,7 @@ if(BUILD_editcap)
)
set(editcap_FILES
editcap.c
+ version_info.c
image/editcap.rc
)
add_executable(editcap ${editcap_FILES})
@@ -1347,7 +1349,6 @@ if(BUILD_dumpcap AND PCAP_FOUND)
${NL_LIBRARIES}
)
set(dumpcap_FILES
- ${CMAKE_BINARY_DIR}/version.h
capture_opts.c
capture-pcap-util.c
capture_stop_conditions.c