aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b87fccf358..70a4cf3191 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -135,6 +135,7 @@ set(WIRESHARK_C_ONLY_FLAGS
# The following are C only, not C++
-Wc++-compat
-Wdeclaration-after-statement
+ -Wlogical-op
-Wno-pointer-sign
-Wold-style-definition
-Wshadow
@@ -143,7 +144,6 @@ set(WIRESHARK_C_ONLY_FLAGS
set(WIRESHARK_EXTRA_C_FLAGS
-pedantic
-Woverflow
- -Wlogical-op
-Wno-overlength-strings
-fstrict-overflow -Wstrict-overflow=4
-Wunreachable-code