aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorJakub Zawadzki <darkjames@darkjames.pl>2014-05-22 23:04:40 +0200
committerAnders Broman <a.broman58@gmail.com>2014-06-09 12:02:27 +0000
commitfcb710baec3caa30c2cb7c444bddbe087fc86574 (patch)
tree1ff3f1c4d9b5dca0794162a1000bede1b3a128e6 /wsutil/Makefile.am
parent66695661992beb054eff219dd73a23559220c867 (diff)
Add sse4.2 optimized function ws_mempbrk_sse42()
In text protocols, like SIP, lot of time is spend guint8_pbrk(), assume that text is not binary (no NULs), and use SSE4.2 pcmpistri instruction. Also move & rename guint8_pbrk() from tvbuff.c as _ws_mempbrk. HAVE_SSE42 must be defined to use _ws_mempbrk_sse42() only activaded for Windows currently. Change-Id: Ic853d84805bdb6492c4f45d2bcc79a973fd9804e Reviewed-on: https://code.wireshark.org/review/1730 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index ed82c9ab6e..98273637f0 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -52,6 +52,10 @@ if NEED_STRPTIME_LO
wsutil_optional_objects += @STRPTIME_LO@
endif
+## if SSE42_SUPPORTED
+wsutil_optional_objects += libwsutil_sse42.la
+## endif
+
include ../Makefile.am.inc
include Makefile.common
@@ -62,6 +66,8 @@ if HAVE_WARNINGS_AS_ERRORS
AM_CFLAGS += -Werror
endif
+noinst_LTLIBRARIES = libwsutil_sse42.la
+
lib_LTLIBRARIES = libwsutil.la
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
libwsutil_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
@@ -74,6 +80,11 @@ libwsutil_la_SOURCES = \
$(LIBWSUTIL_SRC) \
$(LIBWSUTIL_INCLUDES)
+libwsutil_sse42_la_SOURCES = \
+ ws_mempbrk_sse42.c
+
+libwsutil_sse42_la_CFLAGS = $(AM_CFLAGS) -msse4.2
+
EXTRA_libwsutil_la_SOURCES= \
inet_aton.c \
inet_aton.h \