aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /wsutil/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am174
1 files changed, 135 insertions, 39 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 7606b6198d..95c57d2582 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -18,7 +18,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) -DWS_BUILD_DLL \
@@ -35,8 +34,65 @@ if HAVE_OS_X_FRAMEWORKS
wsutil_optional_abi_includes += cfutils.h
endif
+# Header files that don't declare replacement functions for functions
+# present in the APIs/ABIs of some, but not all, targets.
+libwsutil_nonrepl_INCLUDES = \
+ adler32.h \
+ aes.h \
+ base64.h \
+ bits_count_ones.h \
+ bits_ctz.h \
+ bitswap.h \
+ buffer.h \
+ clopts_common.h \
+ cmdarg_err.h \
+ copyright_info.h \
+ crash_info.h \
+ crc6.h \
+ crc7.h \
+ crc8.h \
+ crc10.h \
+ crc11.h \
+ crc16.h \
+ crc16-plain.h \
+ crc32.h \
+ des.h \
+ eax.h \
+ filesystem.h \
+ frequency-utils.h \
+ g711.h \
+ inet_addr.h \
+ inet_ipv6.h \
+ interface.h \
+ jsmn.h \
+ md4.h \
+ md5.h \
+ mpeg-audio.h \
+ nstime.h \
+ os_version_info.h \
+ pint.h \
+ plugins.h \
+ privileges.h \
+ processes.h \
+ rc4.h \
+ report_err.h \
+ sha1.h \
+ sha2.h \
+ sign_ext.h \
+ sober128.h \
+ str_util.h \
+ strnatcmp.h \
+ tempfile.h \
+ time_util.h \
+ type_util.h \
+ unicode-utils.h \
+ utf8_entities.h \
+ ws_cpuid.h \
+ ws_mempbrk.h \
+ ws_mempbrk_int.h
+
# Header files for functions in libwsutil's ABI on this platform.
-libwsutil_abi_INCLUDES = \
+libwsutil_abi_INCLUDES = \
$(libwsutil_nonrepl_INCLUDES) \
$(wsutil_optional_abi_includes)
@@ -51,15 +107,57 @@ endif
noinst_LTLIBRARIES = libwsutil_sse42.la
lib_LTLIBRARIES = libwsutil.la
-# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-libwsutil_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
-LIBWSUTIL_SRC = $(LIBWSUTIL_COMMON_SRC)
-LIBWSUTIL_INCLUDES = $(LIBWSUTIL_COMMON_INCLUDES)
+libwsutil_la_SOURCES = \
+ $(libwsutil_nonrepl_INCLUDES) \
+ adler32.c \
+ aes.c \
+ airpdcap_wep.c \
+ base64.c \
+ bitswap.c \
+ buffer.c \
+ clopts_common.c \
+ cmdarg_err.c \
+ copyright_info.c \
+ crash_info.c \
+ crc6.c \
+ crc7.c \
+ crc8.c \
+ crc10.c \
+ crc11.c \
+ crc16.c \
+ crc16-plain.c \
+ crc32.c \
+ des.c \
+ eax.c \
+ filesystem.c \
+ frequency-utils.c \
+ g711.c \
+ inet_addr.c \
+ interface.c \
+ jsmn.c \
+ md4.c \
+ md5.c \
+ mpeg-audio.c \
+ nstime.c \
+ os_version_info.c \
+ plugins.c \
+ privileges.c \
+ rc4.c \
+ report_err.c \
+ sha1.c \
+ sha2.c \
+ sober128.c \
+ str_util.c \
+ strnatcmp.c \
+ tempfile.c \
+ time_util.c \
+ type_util.c \
+ unicode-utils.c \
+ ws_mempbrk.c
if HAVE_OS_X_FRAMEWORKS
-LIBWSUTIL_SRC += cfutils.c
-LIBWSUTIL_INCLUDES += cfutils.h
+libwsutil_la_SOURCES += cfutils.c cfutils.h
endif
libwsutil_sse42_la_SOURCES = \
@@ -67,43 +165,41 @@ libwsutil_sse42_la_SOURCES = \
libwsutil_sse42_la_CFLAGS = $(AM_CFLAGS) $(CFLAGS_SSE42)
-libwsutil_la_SOURCES = \
- $(LIBWSUTIL_SRC) \
- $(LIBWSUTIL_INCLUDES)
-
-EXTRA_libwsutil_la_DEPENDENCIES = \
- $(wsutil_optional_objects)
+# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
+libwsutil_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
libwsutil_la_LIBADD = \
- $(LTLIBOBJS) \
+ $(LTLIBOBJS) \
@COREFOUNDATION_FRAMEWORKS@ \
- @GLIB_LIBS@ \
- @LIBGCRYPT_LIBS@ \
+ @GLIB_LIBS@ \
+ @LIBGCRYPT_LIBS@ \
+ $(wsutil_optional_objects)
+
+EXTRA_libwsutil_la_DEPENDENCIES = \
$(wsutil_optional_objects)
EXTRA_DIST = \
- .editorconfig \
- cfutils.c \
- cfutils.h \
- CMakeLists.txt \
- Makefile.common \
- file_util.c \
- file_util.h \
- getopt_long.c \
- getopt_long.h \
- inet_addr-int.h \
- inet_aton.c \
- inet_aton.h \
- inet_ntop.c \
- inet_pton.c \
- popcount.c \
- popcount.h \
- strptime.c \
- strptime.h \
- win32-utils.c \
- win32-utils.h \
- ws_mempbrk_sse42.c \
- wsgcrypt.h \
+ .editorconfig \
+ cfutils.c \
+ cfutils.h \
+ CMakeLists.txt \
+ file_util.c \
+ file_util.h \
+ getopt_long.c \
+ getopt_long.h \
+ inet_addr-int.h \
+ inet_aton.c \
+ inet_aton.h \
+ inet_ntop.c \
+ inet_pton.c \
+ popcount.c \
+ popcount.h \
+ strptime.c \
+ strptime.h \
+ win32-utils.c \
+ win32-utils.h \
+ ws_mempbrk_sse42.c \
+ wsgcrypt.h \
wsgetopt.h
CLEANFILES = \