aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-24 05:01:57 +0000
committerJoão Valverde <j@v6e.pt>2016-04-04 22:04:03 +0000
commitbe96c3d64c9d5838e7319d5dd4a2ecd45897a024 (patch)
treeccd8c3c80a77ad1c70cb5aeab36e31a8239989b4 /wsutil/Makefile.am
parentcc82687093c572af1cfb8ceab0abbb3ba4e36660 (diff)
autotools: Clean up libm tests
Change-Id: I01bef4d6c2cf2280935d573166652d905948028d Reviewed-on: https://code.wireshark.org/review/14806 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index c69b9bc3c6..6a50a89453 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -43,7 +43,6 @@ libwsutil_abi_INCLUDES = \
# Optional objects that I know how to build. These will be
# linked into libwsutil if necessary.
wsutil_optional_objects = \
- @FLOORL_LO@ \
@GETOPT_LO@ \
@INET_ATON_LO@ \
@INET_NTOP_LO@ \
@@ -73,14 +72,16 @@ libwsutil_la_SOURCES = \
$(LIBWSUTIL_SRC) \
$(LIBWSUTIL_INCLUDES)
+if !HAVE_FLOORL
+libwsutil_la_SOURCES += floorl.c floorl.h
+endif
+
libwsutil_sse42_la_SOURCES = \
ws_mempbrk_sse42.c
libwsutil_sse42_la_CFLAGS = $(AM_CFLAGS) $(CFLAGS_SSE42)
EXTRA_libwsutil_la_SOURCES = \
- floorl.c \
- floorl.h \
inet_aton.c \
inet_aton.h \
inet_ntop.c \