aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2018-10-02 19:00:01 +0200
committerAnders Broman <a.broman58@gmail.com>2018-10-03 03:49:16 +0000
commit107205c2becb5a16b214cdbc471833fdfee077ab (patch)
tree1f08520cda0277e665db3c21ad1eca483f74928f /wsutil/CMakeLists.txt
parent105f2d68d81416e322152f0edc62ec1434a9d604 (diff)
wsutil: get_datafile_dir: avoid hard-coded build directory
With autotools, it was possible that the binary was located in a .libs directory, but with CMake the executables directory and data directory are the same (except macOS with app bundles). Use this property to get rid of the hard-coded build directory. Helps with reproducible builds. Bug: 15163 Change-Id: I5b8807a03783a9919fba7b0cc83f5c162caa8052 Reviewed-on: https://code.wireshark.org/review/29984 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 36078f30cb..dfc649932a 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -306,13 +306,6 @@ if(NOT WIN32)
)
endif()
-# Export build-time datadir (note: the macro "DATAFILE_DIR" is defined in
-# config.h and points to the install-time data directory, hence the different
-# name).
-set_property(SOURCE filesystem.c APPEND PROPERTY
- COMPILE_DEFINITIONS BUILD_TIME_DATAFILE_DIR="${DATAFILE_DIR}"
-)
-
CHECKAPI(
NAME
wsutil