aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2002-03-02 20:41:08 +0000
committerGuy Harris <guy@alum.mit.edu>2002-03-02 20:41:08 +0000
commit761ae95b199c474ebe526077a2dbd36044e2701d (patch)
treeea4ea5a557ffcefb58d5ce2f2ee22098994aeff3 /wiretap/configure.in
parent95ee7f0ac1fa3c000a6bea4738eb15c88a4497d8 (diff)
From Joerg Mayer: get rid of "-Wno-unused" flag in some configure
scripts, and check in changes to add _U_ to some unused arguments (some other should perhaps be used, so we leave the _U_ out so that the warnings serve as a reminder to check those). svn path=/trunk/; revision=4847
Diffstat (limited to 'wiretap/configure.in')
-rw-r--r--wiretap/configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/wiretap/configure.in b/wiretap/configure.in
index e3431e5615..86345a3154 100644
--- a/wiretap/configure.in
+++ b/wiretap/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.36 2002/02/27 09:42:52 guy Exp $
+# $Id: configure.in,v 1.37 2002/03/02 20:41:07 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -29,16 +29,16 @@ AC_PATH_PROG(LEX, flex)
AC_SUBST(FLEX_PATH)
#
-# If we're running gcc, add '-Wall -W -Wno-unused' to CFLAGS, and add
-# '-D_U_="__attribute__((unused))"' as well, for future use when we
-# remove '-Wno-unused'.
+# If we're running gcc, add '-Wall -W' to CFLAGS, and add
+# '-D_U_="__attribute__((unused))"' as well, so we can use _U_ to
+# flag unused function arguments and not get warnings about them.
#
# Otherwise, add '-D_U_=""', so that _U_ used to flag an unused function
# argument will compile with non-GCC compilers.
#
-AC_MSG_CHECKING(to see if we can add '-Wall -W -Wno-unused' to CFLAGS)
+AC_MSG_CHECKING(to see if we can add '-Wall -W' to CFLAGS)
if test x$GCC != x ; then
- CFLAGS="-D_U_=\"__attribute__((unused))\" -Wall -W -Wno-unused $CFLAGS"
+ CFLAGS="-D_U_=\"__attribute__((unused))\" -Wall -W $CFLAGS"
AC_MSG_RESULT(yes)
else
CFLAGS="-D_U_=\"\" $CFLAGS"