aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2007-04-22 23:52:38 +0000
committerGuy Harris <guy@alum.mit.edu>2007-04-22 23:52:38 +0000
commit3b884cb0dfa0f7d89edfb04f16aae77106580324 (patch)
tree890de8bf599719d71bef67cefbf60dae0511b587 /wiretap/configure.in
parentaff8dc680daaf1bcf75a45670ad3aa21771e95f2 (diff)
Propagate Joerg's fix to make --enable-extra-gcc-checks turn off
--enable-warnings-as-errors (if any tests enabled by --enable-extra-gcc-checks are safe to treat as errors, they're safe to turn on by default). svn path=/trunk/; revision=21515
Diffstat (limited to 'wiretap/configure.in')
-rw-r--r--wiretap/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/wiretap/configure.in b/wiretap/configure.in
index 117135bab9..f0c7dad22a 100644
--- a/wiretap/configure.in
+++ b/wiretap/configure.in
@@ -30,6 +30,7 @@ AC_ARG_ENABLE(extra-gcc-checks,
AC_HELP_STRING( [--enable-extra-gcc-checks],
[Do additional -W checks in GCC. @<:@default=no@:>@]),
[
+ wiretap_extra_gcc_flags=$enableval
if test $enableval != no
then
AC_WIRETAP_GCC_CFLAGS_CHECK(-pedantic)
@@ -69,7 +70,7 @@ AC_ARG_ENABLE(warnings-as-errors,
AC_HELP_STRING( [--enable-warnings-as-errors],
[Treat warnings as errors (only for gcc). @<:@default=yes@:>@]),
[
- if test "x$GCC" = "xyes" && test "x$enableval" == "xyes"; then
+ if test "x$GCC" = "xyes" -a "x$enableval" == "xyes" -a "x$wireshark_extra_gcc_flags" != "xyes"; then
with_warnings_as_errors="yes"
AC_MSG_RESULT(yes)
else
@@ -77,7 +78,7 @@ AC_ARG_ENABLE(warnings-as-errors,
AC_MSG_RESULT(no)
fi
],
- if test "x$GCC" = "xyes" && test "x$wireshark_extra_gcc_flags" = "x"; then
+ if test "x$GCC" = "xyes" -a "x$wireshark_extra_gcc_flags" = "x"; then
with_warnings_as_errors="yes"
AC_MSG_RESULT(yes)
else