aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/Makefile.am
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2007-07-30 20:22:37 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2007-07-30 20:22:37 +0000
commit5c9beb6180bf9d3a6bbbbf42eb5c82dcda1e0f85 (patch)
tree9cbfb86dfe1b0a83c37e8528dc019ef3885e0733 /wiretap/Makefile.am
parentc17ebb799f3bce6b87858ab69c4f134a0439ad2e (diff)
Add comments to various %option items to explain what they're doing.
Move the %options to the beginning if they weren't already there, and put them in the same order in all files. Add "prefix=" options to .l files that don't already have them, so we don't have to pass a "-P" option. Add "never-interactive" and "noyywrap" options to our lexical analyzers, to remove extra isatty() checks and to eliminate the need for yywrap() from the Flex library. Get rid of %option nostdinit - that's the default. Add .l.c: rules to Makefile.am files, replacing the rules for specific .l files. Have those rules all check that $(LEX) is set. Update the address for the FSF. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@22424 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'wiretap/Makefile.am')
-rw-r--r--wiretap/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/wiretap/Makefile.am b/wiretap/Makefile.am
index 078486cbd4..4aeb98cacc 100644
--- a/wiretap/Makefile.am
+++ b/wiretap/Makefile.am
@@ -79,12 +79,9 @@ ascend-grammar.c : ascend-grammar.y
fi
$(YACC) -d -p ascend -o ascend-grammar.c $(srcdir)/ascend-grammar.y
-ascend-scanner.c : ascend-scanner.l
+.l.c:
@if [ ! -x "$(LEX)" ]; then \
echo "Neither lex nor flex was found"; \
exit 1; \
fi
- $(LEX) -Pascend -oascend-scanner.c $(srcdir)/ascend-scanner.l
-
-k12text.c : k12text.l
- $(LEX) -ok12text.c $(srcdir)/k12text.l
+ $(LEX) -o$@ $<