aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2023-05-26 22:44:19 +0100
committerJoão Valverde <j@v6e.pt>2023-05-26 22:55:47 +0100
commitf0e4c5262dab59a880a207352fce80a746ec2281 (patch)
tree91e6370e3ff999ef1d6bbb070a04e0713973e940 /wiretap/CMakeLists.txt
parent69327113ef4b2c30cee7398cadd1e4139984381b (diff)
Revert "CMake: Replace deprecated module FindPythonInterp"
This reverts commit d6380e7ae40ec53cbd9119e9527546656f82d660. Turns out we were unwittingly still using FindPythonInterp instead of FindPython3.cmake, via LocatePythonModule.cmake, nd this commit actually enabled FindPython3.cmake. Also turns out FindPython3.cmake is far too clever and very buggy with MSYS2. It will usually not find the correct python binary and fail in many suprising ways, depending on which combination of Python Windows installations is present.
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index ff4b77ffe0..b021208335 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -151,7 +151,7 @@ file(GENERATE
)
add_custom_command(
OUTPUT wtap_modules.c
- COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/make-regs.py wtap_modules wtap_modules.c @wtap_modules.in.txt
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/make-regs.py wtap_modules wtap_modules.c @wtap_modules.in.txt
DEPENDS ${CMAKE_SOURCE_DIR}/tools/make-regs.py ${WIRETAP_MODULE_FILES}
"${CMAKE_CURRENT_BINARY_DIR}/wtap_modules.in.txt"
COMMENT "Making wtap_modules.c"