aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-06-06 12:01:44 -0700
committerAnders Broman <a.broman58@gmail.com>2018-06-07 04:01:37 +0000
commit9031281672206803c4344a68a7f1c2f3b230fa56 (patch)
treeedf2f0586af505b1305bf92f09845b201d5e9132 /wiretap/CMakeLists.txt
parent6bb5a7af6621e8c020a8856466079c3a10d21602 (diff)
CMake: Get rid of FULL_SO_VERSION
gd2e0724afc moved our library versions into their own variables named FULL_SO_VERSION. They're no longer used and interfere with tools/release-update-debian-soversions.sh so remove them. Fix some shellcheck warnings in release-update-debian-soversions.sh while we're here. Bug: 14778 Change-Id: I0eb0bb4ab4c482bdb8a94f8c18aa04c6c83c781b Reviewed-on: https://code.wireshark.org/review/28068 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 3bfc5870b1..b0aebf04e8 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -117,13 +117,11 @@ add_library(wiretap
add_dependencies(wiretap version)
-set(FULL_SO_VERSION "0.0.0")
-
set_target_properties(wiretap PROPERTIES
PREFIX "lib"
COMPILE_DEFINITIONS "WS_BUILD_DLL"
LINK_FLAGS "${WS_LINK_FLAGS}"
- VERSION ${FULL_SO_VERSION} SOVERSION 0
+ VERSION "0.0.0" SOVERSION 0
FOLDER "DLLs"
)