aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-12-31 10:15:28 -0800
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2022-01-01 08:09:12 +0000
commit4e417b8e7cabe83a01921f4df2281ea2d5a2a507 (patch)
tree33a259ff64daeb9c4fe36731ef4e0bbbc3800dc7 /wiretap/CMakeLists.txt
parent67f05835cac0a26636a7e04739a4cc0dd225c077 (diff)
Windows: UTF-8 harder.
Set the process code page in wireshark.exe.manifest to UTF-8 as described at https://docs.microsoft.com/en-us/windows/apps/design/globalizing/use-utf8-code-page Make sure each of our command line resource files includes our main manifest. Rename wiretap.rc to libwiretap.rc to match our other libraries.
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 34d0611f6c..0b90f380af 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -164,7 +164,7 @@ set_source_files_properties(
add_library(wiretap
${WIRETAP_FILES}
- ${CMAKE_BINARY_DIR}/image/wiretap.rc
+ ${CMAKE_BINARY_DIR}/image/libwiretap.rc
)
set_target_properties(wiretap PROPERTIES