aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2017-12-24 20:44:46 -0500
committerRoland Knall <rknall@gmail.com>2017-12-27 19:28:22 +0000
commite65ce97f1ad432519a6dc2e6618683d9f7dbf27b (patch)
treed10650cc47d1ad7bbbc7805d3da6a5906de47d75 /ui/qt/CMakeLists.txt
parente641846837477b6cefa3e70d25ee45f4713096b2 (diff)
Add template helper for simple Qt tree models
Provide template class for data item of a tree model that has simple parent/child relationship and can handle the APIs necessary to navigate between parent/children. Also provide template class to shim between QAbstractItemModel and inherited class to handle "tree navigation" API. It's not supported by Qt 4.8, so hold off on actually using it. This saves a bunch of typing and enforces type safety. Change-Id: I431dee73625f5335b45fe9c6e4c2973932860ad8 Reviewed-on: https://code.wireshark.org/review/24988 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index b2cd1f2e34..202d34c77c 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -88,6 +88,7 @@ set(WIRESHARK_MODEL_HEADERS
models/sparkline_delegate.h
models/supported_protocols_model.h
models/timeline_delegate.h
+ models/tree_model_helpers.h
models/uat_delegate.h
models/uat_model.h
models/url_link_delegate.h