aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorRoland Knall <roland.knall@br-automation.com>2018-01-12 13:15:20 +0100
committerRoland Knall <rknall@gmail.com>2018-01-12 12:49:14 +0000
commitac9c89de65f29411c435a3ed38abf333fd7b1b09 (patch)
tree718f337a4237e398157aff68abcfb62159c36aa1 /ui/qt/CMakeLists.txt
parentc1301a486217f0027e11ae90816006f723bf4b9e (diff)
Qt: Add InfoProxyModel
Add an identity model, which can be used to display non-selectable information at the end of any list Change-Id: Iaca436f34cb8e5b251eb0dc00ea2c0ce1bd9e0e2 Reviewed-on: https://code.wireshark.org/review/25280 Petri-Dish: Roland Knall <rknall@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index ad09591e56..3e6eda79a0 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -83,6 +83,7 @@ set(WIRESHARK_MODEL_HEADERS
models/export_objects_model.h
models/fileset_entry_model.h
models/html_text_delegate.h
+ models/info_proxy_model.h
models/interface_sort_filter_model.h
models/interface_tree_cache_model.h
models/interface_tree_model.h
@@ -306,6 +307,7 @@ set(WIRESHARK_MODEL_SRCS
models/export_objects_model.cpp
models/fileset_entry_model.cpp
models/html_text_delegate.cpp
+ models/info_proxy_model.cpp
models/interface_sort_filter_model.cpp
models/interface_tree_cache_model.cpp
models/interface_tree_model.cpp