aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorRoland Knall <rknall@gmail.com>2017-01-06 11:56:09 +0100
committerAnders Broman <a.broman58@gmail.com>2017-01-22 10:42:30 +0000
commit76cf1d0b0a0b804b24bea6afb4a4620a1607b144 (patch)
tree3999dabb469ff2b71c1b739be6adfabe929449fa /ui/qt/CMakeLists.txt
parent4ff9bddc4608cd6de1c729d1fbc39c9b49740c13 (diff)
Qt: Implement Custom CMake
Implement the custom cmake calls analog to the gtk version Change-Id: I426d2a2df5a4bfb6fc385b970e3944415d3c8afd Reviewed-on: https://code.wireshark.org/review/19563 Petri-Dish: Roland Knall <rknall@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 9899ad7477..2eb0b43beb 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -19,6 +19,8 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+ADD_CUSTOM_CMAKE_INCLUDE()
+
# All .h files which inherit from QObject aka which use the Q_OBJECT macro
# need to go here.
set(WIRESHARK_QT_HEADERS
@@ -164,6 +166,7 @@ set(WIRESHARK_QT_HEADERS
wireshark_application.h
wireshark_dialog.h
wlan_statistics_dialog.h
+ ${WIRESHARK_CUSTOM_QT_HEADERS}
)
if(HAVE_PCAP_REMOTE)
@@ -329,6 +332,7 @@ set(WIRESHARK_QT_SRC
wireless_frame.cpp
wireshark_application.cpp
wireshark_dialog.cpp
+ ${WIRESHARK_CUSTOM_QT_SRCS}
)
if(HAVE_PCAP_REMOTE)
@@ -363,6 +367,7 @@ set(WIRESHARK_QT_TAP_SRC
sctp_assoc_analyse_dialog.cpp
stats_tree_dialog.cpp
wlan_statistics_dialog.cpp
+ ${WIRESHARK_CUSTOM_TAP_SRC}
)
set(WIRESHARK_QT_FILES