aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2016-02-14 19:34:11 +0100
committerStig Bjørlykke <stig@bjorlykke.org>2016-02-15 19:44:27 +0000
commit44f74e7b2657fb8691e59aa86910f818ece31c4d (patch)
treecc711f6bde30ab95fe2778a7a2d36d15f25d1fa0 /ui/qt/CMakeLists.txt
parent8e1ade8516ef74b8bcc64e783400c2d0939250ef (diff)
Qt: Add FindLineEdit with regex search option
Add settings to the QLineEdit context menu to use textual or regular expression search. Use this in Follow Stream and Show Packet Bytes. Change-Id: I3a9f5a923f616629aa40a334921871f98b518f30 Reviewed-on: https://code.wireshark.org/review/13942 Petri-Dish: Stig Bjørlykke <stig@bjorlykke.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Stig Bjørlykke <stig@bjorlykke.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index dbfa3ec02e..ecaf198a68 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -65,6 +65,7 @@ set(WIRESHARK_QT_HEADERS
filter_dialog.h
filter_expression_frame.h
filter_expressions_preferences_frame.h
+ find_line_edit.h
follow_stream_dialog.h
follow_stream_text.h
font_color_preferences_frame.h
@@ -215,6 +216,7 @@ set(WIRESHARK_QT_SRC
filter_dialog.cpp
filter_expression_frame.cpp
filter_expressions_preferences_frame.cpp
+ find_line_edit.cpp
follow_stream_dialog.cpp
follow_stream_text.cpp
font_color_preferences_frame.cpp