aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2017-06-28 20:00:38 -0400
committerRoland Knall <rknall@gmail.com>2017-12-13 16:07:07 +0000
commitb0112e60ada68646b3e304f73f8321f5fb1ddc01 (patch)
tree4b7e3e2503ba90cbfda0c10ccddb783afe43143b /ui/qt/CMakeLists.txt
parentf945b85391976bc59da4b542fe84cb58033bd22e (diff)
Add a model to use for Expert Info dialog.
With the model (and proxy), the following features were added/fixed. 1. Expert severities can be filtered by type 2. Search filter expanded to include summary, protocol and column info 3. Expert info starts with all items collapsed. 4. Context menus for collapse/expand all Bug: 11753 Bug: 13831 Bug: 13842 Change-Id: I8e89c7be441e1f08e18915ef8805609e5c5d0bd1 Reviewed-on: https://code.wireshark.org/review/22458 Reviewed-by: Michael Mann <mmann78@netscape.net> Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 4934fd484b..bb8d02749d 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -34,6 +34,7 @@ set(WIRESHARK_WIDGET_HEADERS
widgets/drag_label.h
widgets/editor_color_dialog.h
widgets/editor_file_dialog.h
+ widgets/expert_info_view.h
widgets/elided_label.h
widgets/field_filter_edit.h
widgets/find_line_edit.h
@@ -64,6 +65,8 @@ set(WIRESHARK_MODEL_HEADERS
models/cache_proxy_model.h
models/decode_as_delegate.h
models/decode_as_model.h
+ models/expert_info_model.h
+ models/expert_info_proxy_model.h
models/fileset_entry_model.h
models/html_text_delegate.h
models/interface_sort_filter_model.h
@@ -244,6 +247,7 @@ set(WIRESHARK_WIDGET_SRCS
widgets/editor_color_dialog.cpp
widgets/editor_file_dialog.cpp
widgets/elided_label.cpp
+ widgets/expert_info_view.cpp
widgets/field_filter_edit.cpp
widgets/find_line_edit.cpp
widgets/follow_stream_text.cpp
@@ -271,6 +275,8 @@ set(WIRESHARK_MODEL_SRCS
models/cache_proxy_model.cpp
models/decode_as_delegate.cpp
models/decode_as_model.cpp
+ models/expert_info_model.cpp
+ models/expert_info_proxy_model.cpp
models/fileset_entry_model.cpp
models/html_text_delegate.cpp
models/interface_sort_filter_model.cpp